Unity bug!! (HELP)!!

Ok, the reason i didn't use the built in unity bug thing is because it takes about 5 hours! The error is this

FMOD failed to initialize ... Error initializing output device.

so the sounds in the project doesn't work, it does this in every project. i tried re-installing it but that doesnt work, also when i have finished testing, i press the play button to stop playing and then it just randomly closes itself, it does this everytime in every project!! HELP ME!!!!!!!!!!!!!!!!!!!!!!!!!

This is possibly an issue with the AudioSrv service in Windows. Go to the TaskManager. Go to the Services tab. Find ‘AudioSrv’ in the list, right click and Restart it. Then restart Unity. Should fix it.

I had an issue with this too but I think I found a solution. If you are on mac, I don’t know what to do, but if you are on windows 7 or higher, go to control panel> Appearance and Personalization> Change sound effects (If you don’t see it, hit Personalization then Change sound effects)> Playback(The Tab). Click on the one that makes the most sense for your audio to come out on and hit set Default. If it still doesn’t work, just in turn, set each to default until it worked. This worked form me.

I removed from scene SoundSource with AudioClip located in Resources folder, reboot computer and it works brilliant. Do not hold clip which is referenced by SoundSorce in Resources or it children, move it to other folder.

I have this issue building with Unity Cloud Build for Android target
[Unity] FMOD failed to get number of drivers … : "Error initializing output device. " (60)
So there is nothing I can do locally, any idea?

https://nahimic.helprace.com/i597-unity3d-fmod-failed-to-initialize-no-sound-with-nahimic

This fixed it for me!! Disable Nahimic services in Task manager! Don’t know what they are, why they’re there (probably not harmful). Been having this problem for months, nothing fixing it and this finally did! Hope this fixes it for someone else!


  • Caspar / NightRunner