Unity Bug, Playmode dont start.

Hello Guys!

Apparently i don’t know if it is a Bug or im just doing something wrong, but anyway here’s the deal:

My Game worked perfectly ( simple OnClick 2D game), but then today as i pressed the Play button, it wont do anything. No errors no alerts, unity just dont start the game. Some days before it had some bugs but it worked. F.e. the OnClick Function, which worked Perfectly, didn’t work anymore. Actually unity was blocking any mouse interaction while in Playmode. Now it wont even load the GameObjects that were in the game…

Does anybody have same issues? Or did i just fkd something up ? Oo… Hewlp…

Could be one of those “start at the bottom” type things, restart your PC then check your HDD for corruption: chkdsk (if it’s Windoze, not sure of the Mac command). If you’re not using an SSD, might run a defrag right afterwards just to be thorough… Then check your source, rebuild/compile and try running the game again :wink:

Hey! Thanks for the reply!

Apparently the Problem was that Unity set the timeScale to zero ( dont know why…). So after i fixed that, the Game Started normaly but the OnClick function still does not work ( well sometimes it does… but after i restart the program it does not…)
Its very strange, since when i build and run the game on android, it seems to work perfectly…but not in unity. It looks like the mouse is not recognized by the Game…

I had the same bug.

The solution:

Open the task manager and stop every adb.exe you can find.

Then it should work again.