Unity build crashes when running on some devices

After transferring the project from Unity 2020.3.22f1 for 2021.3.6f1 on some devices, the app crashes at the time of launch. On some devices, the problem is solved if you run the application as an administrator, but this only helps on some computers. The application uses FMOD, but when the plugin is removed, the error repeats.
Here is the result of crash.dump debugging:

0xC0000005
The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
> > UnityPlayer.dll!audio::mixer::ApplyBlendedSnapshots(FMOD::System * system, const audio::mixer::Audio Mixer Constant & constant, audio::mixer::AudioMixerMemory & memory, float deltaTime) Line 876 C++

I tried changing the security policy, disabling the firewall and antivirus, but nothing helps.
What else can be done to fix this error?

8299260--1088283--Logs.zip (85.1 KB)

Are you able to reproduce this yourself? Or have you only received crash reports from people in the wild?

Yes, I can. I have a computer where everything starts, and where the application does not work.

In that case, could you capture a full crash dump (instructions here, use dump type 2 (full): https://docs.microsoft.com/en-us/windows/win32/wer/collecting-user-mode-dumps) and send it to me?

Link to the full dump: https://drive.google.com/file/d/1i6ALRkQji69fWpFlbCC-qbD5B-IQh9Q5/view?usp=sharing

So, this crash is happening when initializing an "AudioMixer" object in your scene. The name of this object is "GlobalEffectAudioMixer". It seems that the group connections inside this objects aren't valid.

Now, this is clearly a bug in Unity and we should be crashing on that. However, the audio team is currently on vacation and I don't know exactly how that code works. Could you try finding this audio mixer in your project and seeing if tinkering with it helps at all?

I checked the Audio Mixer, then reassembled the logic asset bundle and it helped! Thanks for the hint where to look for the problem!