Unity build freezes on gray screen after splash screen on android

Hi! I’ve been working on a game in Unity engine for the last week. Everything works fine on the Unity editor but when i build the .apk and run it on an android device it starts, shows the Unity splash screen, but then the screen stays gray (the same gray of the Unity splash screen) and doesn’t do anything more. I’ve been doing some research on how to fix this but i couldn’t find much info targeting this exact issue. I tried to run the adb logcat but i can’t make it work. I am a total newbie about developing as you can see.

I am using a Mac with OS 10.13.6 High Sierra.
My Unity software is up to date.
My phone is a Galaxy S9 and i enabled the developer features.
The game shows no errors or warnings on the Unity console.

I will really appreciate any kind of help you can offer me.

I tried running the game on my Android device via Unity Remote 5 and it works fine. But if i try running it from the apk file it freezes on the gray screen. Also tried changing OpenGL3.0 for OpenGL2.0 as i saw in some post on internet but the result was the same.

Did you find a fix? Same thing is happening with my app :frowning: