Unity claiming "no network connection"

We are having an issue with one of our computers claiming in unity that there is

“no network connection”

This comes up on the login screen.

Oddly by disconnecting the internet we were able to get to the login windows and put in the ID pass word, and then reconnect the internet and connect to the unity servers and see projects in the proper cloud database. On entering unity however we then found that all of the services were also flagged as having no connection in the editor, so all services were no longer functional again.

Anyone have some ideas?

We are running through all sorts possible network issues trying to find something.

Windows 10 running Unity-2017-2.0f3

Hi guys, i had the same problem.

Go to asset store window. Sign in. Problem solved for me.

Keep Unity Editor opening and then open Unity-Hub then choose AccountManage LicenseCheck for Updates. Wait for update success then get back to Unity Editor the service will online.

Hope this tips help.

I’ve ran into same issue with Win10 and Unity 2017.2.0f3. Strange thing is it seems to indicate that I am actually logged in on the top of the dashboard, as it shows “Welcome Zed Z” and lets me click on the icon to logout of my account. I then tried to logout and login again, in which then it gets into really a really funky state of briefly flashing the login fields before showing the “No Network Connection” screen again. Tried multiple times, and it keeps doing that.
I still have 2017.1.1f installed on the same machine and that still works fine. I also tried installing 2017.2.0f3 on a macOS 10.13 and that works fine too.

I am having this same problem.

  • Windows 7 Professional 64bit
  • Windows firewall disabled.
  • Turned off Malwarebytes Antimalware

Using manual activation I can run the latest 2017 version of Unity, downloaded Feb8th or 9th, personal edition.

From inside Unity I can open the asset store window and browse normally until I go to download something then it wants me to log in and that is when I continue to get the “no network connection” window.

I have an older version of Unity personal on a second computer, I want to upgrade that PC to the latest Unity but don’t want it to break that one so I am afraid to test it to see what happens.

Simply closing Unity Hub solved this issue for me.

We still havn’t come up with a solution to this issue. I have not been able to reproduce it on other computers either. I am going to see if he has tried to update to a more recent version or anything recently, I am hoping that it was a version independent issue.

Having the same trouble too. win10x64 unity3d.2017.03.0f3-x64

Problem solved. Trying click to “manual activation”. This stopped blink, then normally activated.

Same problem here. Windows 10, can accsess Assets store, but services like Collaboration do not work.

I am having the same problem. In my case, the problem is my VPN. I am currently using NordVPN/OpenVPN, but it’s possible other network clients may be an issue. Some AntiVirus packages, such as Kaspersky, have network protection and monitoring that might be an issue? I have no solutions, just throwing out some ideas.

leaving the project open and opening unity hub fixed it for me

its 2020 ending, and im also facing this issue

In my case “sign in” in Unity Hub helped.

it is 2021 ending, and im also facing this issue
Solution:
In my case I was trying to use Unity Hub 3.0 which is beta,
In Unity Hub 3.0 I changed my channel from beta to production (which backed me to Unity Hub 2.x) solved my problem.

its 2021 ending, and im also facing this issue

Ctrl + Shift + Esc, kill all Unity/Unity Hub running processes.

Restart Unity.

This worked for me.

Hello.

Same Problem.
Windows 11 x64
Please fix this problem. Here is a screenshot: