Unity closes when opening project

So, i have just downloaded Unity Hub on a new install. Now i made a project with 2019.3, but whenever i try to open it after creating it, Unity just closes. No error, no nothing. In task manager, Unity Editor just starts, stops responding, and then stops. Why is this, and what should i do? Like i said, this is a fresh Windows install.

I have the same problem and it doesn’t matter what project or Unity version I try to open the project with. After clicking on the project the Unity Hub window disappears as normal, the Unity Editor splash screen is visible, then the Unity Hub window reappears and a couple of seconds later the Unity Editor process quits. No error messages.

Funny enough I can create a new project via Unity Hub and the editor opens. But I can’t re-open it through the Hub. I tried uninstalling and reinstalling, also deleted Unity Hub folders under %APPDATA%.


Solution: I found the solution in my personal case. It was caused by a deactivated Ethernet network adapter even though my WiFi network adapter was activated and provided the internet access. Unity Hub/Unity Editor somehow seems to insist that the Ethernet network adapter is enabled.

It worked! OMG I have spent hours trying to figure out why Unity worked all day and then, after a reboot, fails to open. I was in the later case like @sebastianzander - with Unity running I had switched from my glitchy wifi adapter to a wired ethernet connection. I then disabled the Wi-Fi connection and worked throughout the day. Unity later was unable to load (just a splash screen after selecting my project from the hub, then nothing) … but simply re-ENABLING MY WI-FI ADAPTER SOLVED THE PROBLEM. And Unity boots right up like expected. I didn’t even connect via wi-fi, because I’m still wired. Crazy. Thanks everyone for the help.

Reinstalled Unity multiple times but couldn’t fix the CTD on opening any project, finally found this and disabled my VPN when opening Unity, no crash. What is Unity doing that having a VPN causes a crash to desktop with no error message?

I have read other messages, but my problem is my laptop does not have any Ethernet port. Therefore, I cannot activate the Ethernet adaptor. I have no idea how to solve this. Hope someone can help here. Many thanks in advance.

For me it was an issue with licenses. There was no error message but I noticed in the logs that it couldn’t find the license. I had to remove the license from my machine via the Unity subscription website and then re-add it in hubs. Then I was able to open the project.