Unity Cloud iOS Build not saving credentials

I’m trying to set up my first Unity Cloud build for iOS. I enter all the details in the service tab and get to submitting the credentials.

I enter all the required information and click the “Next: build ->” button which on first glance appears unresponsive until you scroll to the top of the service tab and see its states “Saving…”. But it doesn’t progress.

I tried doing a build regardless from the dashboard and the steps prior to the credentials seems successful but then the build log gives me:

  • 93: GIT: Get current revision
  • 94: GIT: Current revision is
  • 95: postcheckoutstatus finished
  • 96: ! pulling
    builtargets failed. no credentials
    found for target ‘default-ios’!
  • 97:
    Build step ‘Execute shell’ marked
    build as failure
  • 98: postbuildstatus
    finished successfully.
  • 99:
    Finished: FAILURE

I also checked the status of the service and the site https://status.cloud.unity3d.com states the Build (service) and Build (queue) are operational

What could be the issue and how can I get over this? I’m trying to evaluate if Cloud build is a time saver at the moment and feel this isnt an appropriate comparison to the pain that is Xcode builds.

I don’t know if you still need an answer, however to any wandering soul that also come across this problem, here’s how I solved it.
In unity, click on “Go to dashboard” in the top right of the cloud services window (or go to Unity ID and select your project).
Click “go to cloud build” and then “Config”.
From this interface, you can create new build targets too.
For me, the build target was there, but it was missing the credentials so I clicked on “show signing credentials” and then put in the bundle identifier and uploaded the provisioning profile and .p12 file. After saving it, I was able to “start new builds” just fine.

Hope this helps!