Unity Collaborate alerting me of conflicts when there are no conflicts

I have been trying to use Unity Collaborate to work on one project on two computers so today I loaded the project on my second computer and it worked fine but when I tried to publish the changes I made I got the error “Conflicts detected. Please resolve them before continuing” the problem with this, however, is below that under conflicted items there are no conflicts. I am not sure what to do about this as I have tried reloading unity, restarting my PC, Changing the revision control Diff/Merge and am still getting this error. does anyone know anything I could do to try and fix it so I can publish my work?

This happens to me all the time, and deleting Library/Collab doesn’t help…
Redownloading the project works, but isn’t a viable workaround for how frequently this happens.

The only thing that does is keeping a 2nd “healthy” collab folder backup, and implanting it instead of the corrupted Library/Collab while Unity is closed.

Working with git in parallel seems to make it worse.
Honestly, I always hated collab, but this, and to a lesser extent the 1 minute delay it imposes on editor startup makes it completely unusable. I hope Unity get their #$@! together on collab soon.

Hi, same problem here - will appreciate help from support


If anyone else has this issue it can be fixed by deleting the files \Library\Collab. You’ll then need to re-sync the project with collab and once that is done it will be all sorted.