Unity Crash on startup

Installed Unity 2.6.1 on my Win7 64bit desktop

When launching the program I get a message titled "Unity Editor" saying that "Unity Editor has stopped working" with an option to close the program. I have seen similar questions asked and answered in much the same way - disabling DEP for unity (Unity.exe) or disabling DEP all together. Neither has worked for me. I have also tried getting rid of my AV/Firewall (Avira/Comodo) to find the cause.

Has anyone had this issue in the past or is there another work-around that may be of assistance?

Alright, I feel a little stupid but I wanted to post this up just in case someone happens to have the same issue. It was fixed by uninstalling/re-installing three times. Yeah, don't ask how that worked but I believe there may have been an issue with Comodo (my firewall) preventing part of the install the first two times around.

I hate searching for a solution to a problem and not seeing an answer in threads so I thought I'd leave this here just in case.

EDIT:

I got it to run but its a pain.

If you run Unity within a sandbox unrestricted it will not crash, but there's a catch. You have to run it from the

COMODO -> Defence+ -> Run a program in the sandbox

menu, every single time. COMODO automagicly adds it to the Add a program list but for some reason it still crashes unless run from the run menu every time. Kind of sucks but it works.

I'll be working on this more to find a fix. I love COMODO and Unity, I'm not giving either one up.

Original Post:

Unity 2.6.1 Win7 64bit COMODO v4.0.141842.828

I have the same issue. I just updated my COMODO to the newest version (the new red interface). Runs fine first install then nothing. I even made it a trusted application, nothing.

Hm,

I have a similar problem, though no solution.

I installed, first startup went fine. Quit, then restarted later - bam, crashes on startup.

Saw this thread, uninstalled, deactivated comodo, installed, started, worked fine, quit, restarted, bam, crashes on startup (still not activated comodo again).

Tried again, uninstalled, made sure comodo was deactivated, installed, started, worked fine, quit, restarted, bam, crashes on startup.

Win7 64-bit as well.

So basically first run after installation works fine, second run = crash.