Unity Crashes during package resolution?

Hey everyone, running into an issue with one of my projects and looking for some help.

| Unity Hub 2.3.0 / Unity 2019.3.0f6 |


So yesterday everything was fine with the project, I was able to load, edit, etc. and pushed some changes to the master via Sourcetree. A colleague did the same, and I pulled down their changes.Once the changes were pulled I opened the project in Unity and during the import I got a hard crash. Not great. Turn the PC back on, try opening the project, hard crash. Reboot, tried clearing out all of the App data - hard crash. I’m not particularly fond of my PC just shutting off and I can open our other projects just fine, so I tried reinstalled Unity Hub and 2019.3.0f6.


Now what seems to happen, is it appears to be crashing at some point while it’s attempting to resolve packages. The process is still running in the BG using up a little memory but nothing else.


What could have changed in the project to cause these issues? I’ve tried reverting to older branches(including one that I pushed myself yesterday) and I run into the same issue.


PC Spec-wise I literally just built this computer like 2 weeks ago as follows:

Ryzen 3900x proc

32GB ram

RX5700 XT 8GB vid card

Everything is installed on an M.2 SSD


I wouldn’t be expecting to be running into any hardware issues, but maybe there’s a driver conflict somewhere? I checked Radeon and the last video update I downloaded was over a week ago, so I don’t believe that’s it…

As an update, I attempted to re-clone the project. Now I’m back to a hard crash during the import process.