Unity crashes in mac on launch when w/o admin privilege

I’ve reported this error quite a few times to Unity, but I haven’t got a useful reply yet.
If I launch Unity via /Applications/Unity (clicking on the icon), it crashes on launch. Period.

If I launch it via the terminal, with su privileges, i.e.
/Applications/Unity/Unity.app/Contents/MacOS/Unity
it works like a charm.

If I try to open a scene by double clicking on it, I get the “unity attempt to write a readonly database” error and unity quits. If I open the same scene via the terminal, i.e
/Applications/Unity/Unity.app/Contents/MacOS/Unity <path_to_scene>/scene1.unity
with admin privileges, it works fine.

Why is it? I don’t have the Quicktime plugins that another post described, so I really don’t understand what the issue is. Any fixes?

Have you tried repairing disk permissions?

  1. Applications > Utilities > Disk Utility
  2. Select your hard drive
  3. Repair Disk Permissons

If that doesn’t help, try verifying/repairing the disk, as well.

Just tried that.
Interestingly, now when I launch Unity via /Applications/Unity, it gives me:
"Fatal Error! attempt to write a readonly database.
UnityEditor.Window.Layout.LoadWindowLayout(String)
"

Any fixes for this? I hate having to launch it via the terminal always…