Unity crashes when I open a project Linux Ubuntu 16.04.

So, I had been using Unity 5.4.0 on this computer (which runs Linux Ubuntu 16.04) for about a week. I went to download an asset from the asset store, but it said something like: this asset needs Unity 5.6.0 (or something like that) to download.

So I go to the page where you can download Unity for Linux. That’s when I realized that there were newer versions for download. So I downloaded the newest version: Unity 2017.2.0b11. Now here’s the annoying part: it takes an HOUR to download. I set it up in the terminal using: sudo dpkg -i unity-editor.deb. After like 15 minutes or so, it finally installed.

I opened it and tried to update the projects by opening them and letting Unity do the rest. Then it just crashed. So I tried to just make a new project. It crashed. I tried again to open the new project. It crashed. I did ALL of this like four times (Downloading, Installing, Running, and Crashing), on about 4 different versions.

Then I realized that this was downloading from “beta.unity3d.com/file/path” for all of them. Some of the earlier ones in the list were: “download.unity3d.com/file/path”. So I downloaded Unity 5.6.0 form the download (not beta) link. Then I ran it. It crashed every single time.

If I can’t figure this out, then I won’t be able to use unity very well at all. (Obviously.) If you guys read this and need a log to figure it out, i would be HAPPY to upload that for you. Thanks for reading and thanks for all of your help.

I’m having the same problem. Suddenly all versions of unity crash trying to open any project or create a new project. Tested on 5.5, 5.6.0xb10, and 2017.2b11. What’s going on? Everything worked great yesterday.

I’m having the same problem too. im so tired, angry and sad, i just want use unity on ubuntu!. i have 17.10 of ubuntu, and unity “unity-editor_amd64-2017.2.0f3”, I swear that if I find the solution I publish it here, because I am tired of searching and nobody gives a solution.

Same problem here on Archlinux

A gist with a detailed report → [Linux] Unity Startup Crash · GitHub