Unity crashes when upgrading


So I have a project for an iOS application. The project file is quiet big (5gb or so). So currently it runs on Unity 4.2 (or early 4.3) I believe. But since quiet a while I tried to upgrade the project to a newer version of 4.3 but it kept crashing. So Is topped and now that Unity 4.5 is out I wanted to upgrade it to this version. But sadly it crashed again.
On the status bar of importing assets it reached about 98-99% so it imported all textures and the bigger Objects. So this time it crashed importing a an .obj file called “modified1451.obj”. But actually I don’t think that there is anything wrong with that file.
Also I kept an I on the activity monitor and it seemed rather well, having more then 600mb Ram free to use. So I don’t think that it is a performance issue.
Which brings me to the point that if it is not the performance and not any of the content of my project, why does it keep crashing. I mean that is kind of annoying as some of the bugfixes (especially in Unity 4.5) would really improve my app.
So also every time I try to import the project it takes me about 3-4 hours. So in that time I can’t use my Macbook so I don’t really have the time to try out too many different things to solve the problem.
I also filed a bug report but until now nobody seemed to be very interested in it.
So I would be very pleased if someone has any suggestions how I can upgrade to a newer version of Unity.

“modified1451.obj” is a mesh in your project. OBJ is a mesh format, just like FBX, or 3ds.

I have the asset importer fail like this on me all the time. It happens because of corruption in the Library folder that Unity builds and maintains with the project. In my case, it’s because somebody forgot to commit a *.meta-file when they committed the asset to SVN, so now there’s different GUIDs associated with the asset across our local Unity Library folders.

Your case is probably different, but I’ll bet you the solution is the same: You need to let Unity open without having to import the assets that cause it to crash. This can be a long, slow, painful and tedious process that involes you going through the editor’s log file (see here for file location) after every single time you tried to open the project, and deleting the offending asset. There might be multiple ones it fails on, and it won’t report more than one at a time.

This sucks, and I’m sorry for ya. Maybe you can get away with removing bunches of assets together to see if you can pin down the culprits faster.

Delete all .meta files in “Assets” directory then delete “Temp” folder in Main directory. Finally delete “Library/metafiles” directory (only metafiles, not whole Library :smiley: ).
That should fix.