Unity dashboard won't let me see Ad Units page

I'm trying to add ads into my game right now. I went to the monetization page on the Unity dashboard but every time I click the Ad Units page or any page under "Project Overview" it just redirects me back to the about page.8462045--1123544--upload_2022-9-23_22-22-47.png

I tried pressing "Get Started" and it says the project was created successfully but nothing happens after that. I'm completely stuck right now.

I am having this issue too, please help...

Great, I thought it was just me. I did just update from legacy analytics to the current version but that didn't solve this problem. Could it be something to do with the fact that I signed up to the Unity Mediation and I am now on the waiting list?

This problem is caused by a configuration issue, and it won't happen with new projects now, we are currently working on it. For old projects with this issue, we can change the configuration for these projects manually, please kindly contact the Unity Ads Support team to do so. Sorry for the inconvenience caused.

Sorry, I tried adding ads for a new project I am working on but this issue still exists.

do you hav an appid or project id we can take a look at?
you can get the project id from the url after /projects/
thanks

Thanks for the response. Here’s my project ID:

69befcca-9f57-4bfa-b4a7-084b626914e6

Hello Nabeel,
I contacted the Unity Service Support team and the issue has been resolved.

Thanks for the help anyway. I appreciate it.

what did they help? could you please share?

I don't really remember but try contacting the Unity Service Support team, I am sure they will help you out.

At this date the problem persists. I want to update my games since long time ago due to PlayStore policies and didn´t find it...I was getting crazy...

Thanks for the info, I will contact them.

I got it, in the button that says "set mediation partner", I selected "I plan to use mediation", and after it, I selected "I only plan to use Unity Ads" and press "OK".

Now it shows Ad Units.