Unity Debugger not working in VS2015 update 2

i dont know if its important or not but when i press ATTACH to Unity button it shows just

**1>------ Build started: Project: Interview.CSharp, Configuration: Debug Any CPU ------
1>C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1820,5): warning MSB3268: The primary reference “UnityEditor” could not be resolved because it has an indirect dependency on the framework assembly “System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089” which could not be resolved in the currently targeted framework. “.NETFramework,Version=v3.5,Profile=Unity Web v3.5”. To resolve this problem, either remove the reference “UnityEditor” or retarget your application to a framework version which contains “System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”.

1>C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1820,5): warning MSB3268: The primary reference “UnityEngine.Networking” could not be resolved because it has an indirect dependency on the framework assembly “System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089” which could not be resolved in the currently targeted framework. “.NETFramework,Version=v3.5,Profile=Unity Web v3.5”. To resolve this problem, either remove the reference “UnityEngine.Networking” or retarget your application to a framework version which contains “System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”.

1>C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1820,5): warning MSB3268: The primary reference “UnityEngine.UI” could not be resolved because it has an indirect dependency on the framework assembly “System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089” which could not be resolved in the currently targeted framework. “.NETFramework,Version=v3.5,Profile=Unity Web v3.5”. To resolve this problem, either remove the reference “UnityEngine.UI” or retarget your application to a framework version which contains “System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”.

1> Interview.CSharp → E:\UnityProjects\Tutorials\Interview\Temp\UnityVS_bin\Debug\Assembly-CSharp.dll
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========**

And nothing happend. i try by going Debug → Attach Unity Debbugger but all in vein .
I am using Unity5.3.5 latest version with VS2015 update2 and windows 10

I ran into the same problem. I sent an email off to the VSTU team and found out that they just discovered an issue with the most recent version of Xamarin. If you have that installed, then that is where your issue is coming from. They’re working on a way for both extensions to play nice, but until then it sounds like the only workaround is to remove Xamarin.