Unity dll, not working AT ALL

Recently my cousin told me to ttry a new game by disney, what happened is when the game was loading since it used Unity Web Player, it asked me to download and install it, i did and finished but when i tried to play the game it said error in launchig Unity, right below that message was something that said Error Details. Clicked that and it said Unity dll was not found. I tried re-installing almost 20 times to no avail. Please Help

Submit a bug report. This site is more for Unity development.

please send an email to support@unity3d.com to solve your problem. game developers use this site to ask their development questions. i'll flag this question for you and then unity staff will answer you soon. if you love to start game development unity has a free version and it's easy to start with it. you can also try other unity made games to see if you can play them or not. take a look at these ones

Our computer is the problem at all. If i use our computer my uberstrike will not be open.if I go and play in playstations it is the way to open it. what are the things to download?what is the real problem?please help me and what is true and exact answer?

i think that our computer is the problem if i play in here it could not open my uberstrike. if i go to computer stations it always be open.please tell me how to open it now.what thing i have to download?what is the real problem?please help me assistance or supporters or other.