Unity doesn't open with log message "No valid Unity Editor license found"

Unity doesn't open when launched from Unity Hub on my Mac - instead Unity hub reopens after about 3 seconds and the Unity icon at the bottom bar closes.

When looking at the Editor logs I see this:
[quote]
[Licensing::Module] Successfully connected to LicensingClient on channel: LicenseClient-unity3
Entitlement-based licensing initiated
[LicensingClient] Licenses Updated successfully in LicensingClient
No valid Unity Editor license found. Please activate your license.
[Package Manager] Server::Start -- Port 55207 was selected
Launching external process: /Applications/Unity_2019_4_13/Unity.app/Contents/Resources/PackageManager/Server/UnityPackageManager

COMMAND LINE ARGUMENTS:
/Applications/Unity_2019_4_13/Unity.app/Contents/MacOS/Unity
-projectpath
/Applications/Project_Unity_2019_4_13
-useHub
-hubIPC
-cloudEnvironment
production
-hubSessionId
130df2d0-9e22-11eb-9665-e5b30c75accb
[Package Manager] Server::Kill -- Server was shutdown
[/quote]

I had my Unity running with a manually activated license successfully for quite a while.
When looking at the license windows in Unity hub, I can see that it is there with no change and is not expired

I also took a look at the Unity License Client log, And I can see it did found my license, but had an exception while parsing it:
[quote]
2021-04-15 20:20:32.360 - INFO - Unity.Licensing.Client.Configuration.PathProviders.PathProviderUtility || Found legacy license file: /Library/Application Support/Unity/Unity_lic.ulf
2021-04-15 20:20:32.364 - ERROR - Unity.Licensing.Client.Services.Helpers.LicenseFilesMapper || Exception caught while parsing license /Library/Application Support/Unity/Unity_lic.ulf
Interop+AppleCrypto+AppleCFErrorCryptographicException: The operation couldn’t be completed. (Internal CSSM error error -2147415791 - Internal error #80010911 at VerifyTransform_block_invoke /AppleInternal/BuildRoot/Library/Caches/com.apple.xbs/Sources/Security/Security-59306.140.5/OSX/libsecurity_transform/lib/SecSignVerifyTransform.c:592)
at Interop.AppleCrypto.VerifySignature(SafeSecKeyRefHandle publicKey, ReadOnlySpan1 dataHash, ReadOnlySpan1 signature, PAL_HashAlgorithm hashAlgorithm)
at System.Security.Cryptography.RSAImplementation.RSASecurityTransforms.VerifyHash(ReadOnlySpan1 hash, ReadOnlySpan1 signature, HashAlgorithmName hashAlgorithm, RSASignaturePadding padding)
at System.Security.Cryptography.RSAImplementation.RSASecurityTransforms.VerifyHash(Byte[ ] hash, Byte[ ] signature, HashAlgorithmName hashAlgorithm, RSASignaturePadding padding)
at System.Security.Cryptography.Xml.SignedXml.CheckSignature(AsymmetricAlgorithm key)
at System.Security.Cryptography.Xml.SignedXml.CheckSignature(X509Certificate2 certificate, Boolean verifySignatureOnly)
at Unity.Licensing.EntitlementResolver.LegacyLicense.LegacyUnityLicense..ctor(String licenseFilePath, X509Certificate2 certificate)
at Unity.Licensing.Client.Services.Helpers.LicenseFilesMapper.MapLicenseFilesToResult(IEnumerable`1 files, ILicensePublicKeyCertificateStore publicKeyCertificateStore, Boolean ignoreLegacyLicenseFiles)
[/quote]

This might a dumb but it got me as well as my designer confused, are you sure you are connected to your account by clicking the user button on the top-right of the hub before going back and managing your license?

I am not logged in, I have an offline manual activation license that was working for me for quite some time now without me logged in

I just had this problem and I restarted Unity about 2 times and it worked. It's just a problem with the Internet Connection.

for me nothing helped , tried everything i could. Luckily got solution from support, this is what i had to do :

1. Delete the license file

(Delete this file:

* Windows: C:/ProgramData/Unity
* Mac: Library/Application Support/Unity)

2. Close and reopen the Hub
3. Reactive license using the **Activate with license request** option
4. Select **Create license request, and** open the .alf file that is created
5. Scroll to the **<MachineBindings>** section add the following directly after the **>** symbol: <Binding Key="4" Value="" />
6. Save changes
7. Reactivate using the manual activation process
9 Likes

[quote=“Celsyum”, post:5, topic: 837071]
for me nothing helped , tried everything i could. Luckily got solution from support, this is what i had to do :

1. Delete the license file

(Delete this file:

* Windows: C:/ProgramData/Unity
* Mac: Library/Application Support/Unity)

2. Close and reopen the Hub
3. Reactive license using the **Activate with license request** option
4. Select **Create license request, and** open the .alf file that is created
5. Scroll to the **<MachineBindings>** section add the following directly after the **>** symbol: <Binding Key="4" Value="" />
6. Save changes
7. Reactivate using the manual activation process

[/quote]
Thank you, it also worked for me

[quote=“Celsyum”, post:5, topic: 837071]
for me nothing helped , tried everything i could. Luckily got solution from support, this is what i had to do :

1. Delete the license file

(Delete this file:

* Windows: C:/ProgramData/Unity
* Mac: Library/Application Support/Unity)

2. Close and reopen the Hub
3. Reactive license using the **Activate with license request** option
4. Select **Create license request, and** open the .alf file that is created
5. Scroll to the **<MachineBindings>** section add the following directly after the **>** symbol: <Binding Key="4" Value="" />
6. Save changes
7. Reactivate using the manual activation process

[/quote]

Thanks, I had the same problem, uninstalled and reinstalled Unity 3 times… This finally solved my problem !

I keep running into this as well -- I think it might be a firewall issue in that Unity Hub can talk to the license server but the Unity instance is for some reason unable to (maybe I allowed Unity Hub to connect when asked, but didn't get asked about the Unity instance or the actual License Server). I suppose that turning off the Microsoft Defender firewall might let it work (and I'll try that the next time I run into this instead of going to create a new license activation yet again).

In any case I followed the above instructions to "Activate with License Request" and that worked for me but that was when I was away from home using my Wi-Fi. Then I got home and connected my display which also has a hardwired Ethernet interface and I suspect the license server decided my license was no longer valid so I had to repeat the entire process. I thought a node-locked license should still work as long as the (wireless in this case) interface is still present.

I cannot believe how frustrating this has been to resolve. Unity just shows a splash screen and then crashes with no additional information.

There are a few clues that the license is considered "invalid" in the Editor.log file which (on Windows) you should be able to find at: "%APPDATA%..\Local\Unity\Editor\Editor.log". On Linux it's at "
~/.config/unity3d/Unity/Editor/Editor.log"

1 Like

Why is this happening? If you hadn't tested the hub why did you make me download it??? How do I open my project now?

I think this is a workaround:
https://support.unity.com/hc/en-us/articles/5541428270356-How-to-activate-a-Unity-license-via-command-line-on-Windows-

[quote=“Celsyum”, post:5, topic: 837071]
for me nothing helped , tried everything i could. Luckily got solution from support, this is what i had to do :

1. Delete the license file

(Delete this file:

* Windows: C:/ProgramData/Unity
* Mac: Library/Application Support/Unity)

2. Close and reopen the Hub
3. Reactive license using the **Activate with license request** option
4. Select **Create license request, and** open the .alf file that is created
5. Scroll to the **<MachineBindings>** section add the following directly after the **>** symbol: <Binding Key="4" Value="" />
6. Save changes
7. Reactivate using the manual activation process

[/quote]
Thank u so much

I wasn't able to resolve my issue. How am I suppose to pitch this product to my contract if I can't even use it.

1 Like

I was not able to resolve this issue on Mac.
This was a new installation. No license dialogue appeared, just "No valid Unity Editor license found".
I tried deleting ~/Library/Application Support/Unity to no avail.

[quote=“fragar65”, post:11, topic: 837071]
I wasn’t able to resolve my issue. How am I suppose to pitch this product to my contract if I can’t even use it.
[/quote]
I figured this out.

  1. I setup Oracle VirtualBox with windows 10 pro edition. There are free ova’s and ISO’s online.
    • I configured the environment with no firewall.
  2. I went to this link: https://unity.com/products/unity-personal.
  3. I installed the hub and then I was able to install the editor edition etc.

I think the issue I had on my laptop was due to the firewall and vpn security FW.

Here's what worked for me: Install Unity Hub. Then you can log in; and open Unity from the hub.

1 Like

So if you're like me you probably downloaded unity via the top and most obvious button on the top of this page:

Start Your Creative Projects and Download the Unity Hub | Unity

Apparently that's step two, you have scroll down and download step 1, the unity hub. Poor design on the website, but maybe this is supposed to be a good way to weed out people who have no business trying to code games :)

3 Likes

[quote=“NachoooXD”, post:4, topic: 837071]
I just had this problem and I restarted Unity about 2 times and it worked. It’s just a problem with the Internet Connection.
[/quote]
it didnt work for me i restarted like 5 times

Hello, I had the same error after install an extra Unity version from :
https://unity.com/releases/editor/archive

I solve the error by updating Unity Hub to the last version (top right corner) then, reactivate licence, then open project.

I got this error when I had an older version of Unity Hub. Updating the Hub fixed the issue.

I got this when I was testing my project on another machine, in which I installed the Editor directly without the Hub. It would be nice if I did not have to log in on a PC just to open my project, particularly since I'm using the free version of the Editor anyway...