Unity doesn't start on Windows 7 x64?

Unity doesn't start for me. Unity 2.6.1 indie version silently just quits when I try to start it. It doesn't matter if I start with Administrator privileges or not, or from command line or not. The process gets created, then almost immediately exits. No log file is created.

I'm using Windows 7 x64, GeForce G210M graphics, all the latest available patches and drivers.

Help?

Did it ever work? You can try holding down the "Alt" button when starting up Unity then creating a new project.

I had tried the Alt thing, and it didn't work.

It turns out that Unity is not compatible with Data Execution Prevention, so I have to create an exception for it, which I'm really unhappy about -- I want to run a secure machine, and there's no really good reason for modern software to not take this into account. If you use JIT code generation, there are ways to mark the data as executable before you jump to it, for example.

Also, it would probably be good if the installer tested for this, and warned you up front.

I have the same problem and have tried all your solutions. It has been working perfectly for months but now it suddenly doesn't start. It's not a DEP problem!

Same config, but my grafics is a 9600 GTM. I have the same problem.

Alt don't work. I have to reinstal every time I want to use the Unity.

I think the problem can be the GeForce Mobile.

If you had enabled DEP (System properties/Advanced/Performance/Data Execution Prevention) for all programs and services, just add Unity.exe to exception list.

this might be a problem with the unity cache. try to go to c:\users(user name)\appdata\locallow\unity. note you will have to manually enter appdata because it's a hidden folder. under unity you should see two folders, webplayer and web player (note the space between web and player on the 2nd instance). click on web player and delete the folder marked cache. when you rerun jumpstart this cache will be regenerated. keep in mind that the first load of the game will be slower than normal. this is because the cache folder is being recreated. good luck.

Is there at least a x64 Windows version of the Unity Player on the horizon? That's really very important (and even more to the Unity people since Adobe has recently released a stable x64 version of Flash).

doesn’t work for me either same problem it gives the error: “fatal error, unable to load database”