unity editor does not respond

i am trying to make a game but every time i start unity and try to test play unity does not respond. starting unity editor can take 20 minutes and sometimes test playing my game is an unlimited error. how can i fix this because now i am on a point where the whole test play does not work.

For anyone still having this issue, I spent a lot of hours trying to figure this out. Ultimately, I fixed it by updating all the packages in the project via the package manager (Window → Package Manager → Select ‘In Project’). Now it’s quicker then it was even when it was working previously.

Good luck

to answer your question @ShadoX
when i launch it takes long. the only thing i know why is that when i look in task manager my project is not responding, this gets fixed after sometime but i don’t get any errors also fixing it takes more than 10 minutes so it is not totally freezing, but when i hit play in the editor it is trying to play the game but again the project is not responding in task manager i know it is something in unity because when i hit play the play button gets grey and than it freezes the program. normally it turns blue. i have 8 gb ddr4 ram, when i am programming i am around the 80%, but sometimes i am at 70% but it is still not responding.

@kajvanschalkwijk What are your computer specifications? imo Unity is resource heavy when playing scenes but the editor itself should be light enough to run on most machines.

And could you specify the error you get when you try to start unity up? A screen shot would be nice.