Unity Editor doesn't load properly

Hi!

So I tried starting up unity after a while of not using it, and found out that it won’t start.
I get the splash screen, I get the sign in screen, I can sign in, I can select a project, up until that, it all works fine. I get the loading bar as the project loads, and then the unity window opens up, with the titlebar with the unity version and project name showing, with the Menu bar with File, Edit, Assets etc. underneath (none of it clickable, though), and a big white empty window underneath that is not responding. And it never goes beyond that.

Things I tried that didn’t work:
restarting the computer
deleting all the Unity folders in %APPDATA% Local, LocalLow, Roaming
updating to the newest unity
deleting unity and installing it again
trying to use Unity without logging in
using unity while disconnected from the internet
trying to load a new project instead of the old one

My system is Windows 7 Pro SP1 64 bit. I’d share a screenshot of how it is right now, but the window is non-responsive (it literally says “Not Responding” in the Task Manager), and a screenshot does not get taken.
Please help me get unity to work!

The lack of responses are disheartening, but today I learnt that unity games do not work either. I get similar behaviour, with a big white empty space, and if tap enough times, I get the “Not responding” dialog from windows, with the options to check for a solution, close the program, or wait for it to respond.