Unity Editor fails silently after first time launch on Windows 7 64

I am testing Unity from few days and I find it an impressive product.

It works without problems on my Windows XP 32 SP 3 machine.

However, I have a problem on my windows 7 64 machine. When the installation ends, it asks if I want to run the Unity Editor. If I answer yes, the Unity Editor launches without any issue. However, if I close it and reopen it from the desktop icon or from the installation folder, it doesn't start anymore. It appears for few instants in Process Explorer and then it closes silently. The log is not updated.

I want to highlight this: the editor starts at the end of installation, so there are no problems with drivers, etc.

I have read about the DEP exceptions and I created one for Unity, I have disabled COMODO but still the problem is there.

Any hints?

I have the same problem too. But I am using Windows Vista 64bit

I also disabled the DEP for unity... as soon as I try opening a new project it says "Unity Editor has stopped working"

if anyone finds the solution PLEASE e-mail me NcR_VaNiSh@yahoo.com

Unity tech report won't reply to me :(

dejapu@gmail.com too please

I had this problem with Windows 7 x64 Home edition (Italian version). I upgraded to x64 professional (English version) and I added a DEP rule and the problem was solved.

Maybe it is a language issue?

I had this problem too, with Windows 7 “Edition Familiale Premium”. I added a DEP rule, and now, Unity works fine. I guess the current version of Unity (3.4.2f3) has solved this problem.

I had this problem with Windows 7 x64 Home edition Premium (French edition). I added a DEP rule, and now Unity works fine. I guess the Unity software has taken care of this problem since last year. The current version is 3.4.2f3.