Unity Editor has not permission on UDP port

Hello.

I have the next problem.

I’m developing a small game that use UDP server for multiplayer.

When I run the game inside Unity Editor is not working.

After many resurches I found that the UPD socket that create the client (the game) has not permision on the firewall.

When I build the game and run it at the same PC works fine and the UPD socket has permision.

Some extra data:

I use Windows 10.

I run Unity as adminstrator.

I have open/pemited the ports (input and output) in the firewall configuration needed for my game.

I have open/permited the conections of Unity.exe in the firewall.

Task Manager screenshot (Spanish Windows it means “not allowed, not restricted”)

What @aress mean with his solution is:

Go to firewall settings → Advanced settings → Invound Rules → Your Unity version → Allow



189493-allow-connection.png

Thanks to @Bunny83. I found a blocking rule in my input rule of the firewall.
I just disabled and Works fine :slight_smile:

Thank you.

P.S. What’s the heck - it look’s like this rule needs to be updated every time Unity Editor updates to a new version.
It’s understandable - but why LTS version updates so frequently?!