Unity editor makes system sounds on compilation warning

When I updated to from Windows 7 to Windows 10 and reinstalled Unity, the editor started playing playing a notification noise when I recompile with a compiler warning. The volume mixer tool tells me it comes from the System Sounds application, so I assume Unity is sending some signal to the OS that wasn’t intercepted on Windows 7. (Or it’s because of the newer Unity version, I suppose?)

I’ve checked around, and other people say they don’t hear any noises from compilation warnings. Is this noise expected behavior? Are there others running Windows 10 who don’t hear it?

I don’t want to hear a noise every time the compiler generates a warning. Is there any way to turn this off without getting rid of that notification sound across my whole system? Thanks!

I hear this sound too. Like you, it disappears if I turn the system sounds to zero in the mixer. I hate the sound but I don’t know how to disable it.