Unity editor not validating

I cant install Unity Editor - its not validating. I have the right hardware requirements.

I’ve tried:

  • putting them in the same parent folder
  • installing every version
  • uninstalling
  • restarting
  • EVERYTHING and it doesn’t work

Hope somebody has a solution. Any ideas?
Please help.