Unity Editor Panels contains weird color/fonts artifacts (screen tearing)

Quite a bit of screen tearing occurs in the tabs especially in the Inspector tab when you click the components tabs. The colors and fonts gets all weird and you have to move your mouse around to clear the artifacts.

The scene editor is mostly okay and doesn’t have screen tearing issues.

I am running on Windows 10 Core i7 5700HQ, Nvidia GTX 960M with the latest drivers. Directx12 is installed, however the Unity Editor at the top says DX11. Could this be the issue?

I have the exact same issue with the same graphics card and Windows 10 Core i7 6700HQ, I was wondering if it might be something to do with the dual graphics cards, but seems unlikely… Here is a screenshot of the sort of thing I see when I activate various tabs:

Notice three things here;
I clicked Hierarchy, and got a dark grey blob over the lighter colour.
I clicked Inspector, and got a dark grey blob were the tab wasn’t.
I clicked the Game tab and then repeatedly pressed the Scene tab, and each time I pressed, the Game and Scene tab fonts got bolder, as if they were re-drawing over the existing text. Also the Scene tab outline disappeared, but the Game tab outline remained…

This is fairly commonplace while using the editor for me, and happens in one way or another for most of the menu items/tabs which I click on… It’s also not uncommon to be presented with large blacked out areas which do not go away when minimising and restoring the editor.

Hey, what Unity version are you guys using?? I only started getting this problem once I updated to 5.4, and then re-installed windows 10.

I tried running my project on another pc running windows 8 and there were no issues. I would love a fix as it actually seems to impact performance when running the game, as it causes lag when I use keyboard inputs.

cheers

I have this issue with Unity 5.4, windows 10, gtx 1080, i7 6700k.

But I also have it on an older pc with Unity ~5.2-5.4, windows 7, ati 7850, and i5 3550k.

It’s not project-specific – if I create a new project it still happens.

It’s still usable, but super annoying. No ideas on how to solve it.

Edit: here’s a screenshot Imgur: The magic of the Internet

It happened to my friend and he was able to fix it by changing unity to use directx 9 instead of directx11:
-Go to: Unity → Properties → Target in window settings
-Change there to directx 9

Hope it helped :slight_smile:

for anyone else that ends up here. I found that something in the NVIDIA Geforce experience caused issues like this for me, and I just turn it off.

I found that the issue can be fixed by using opengl. When you launch unity, add the command line argument “-force-opengl” and this should fix the issue. Would love to see unity address this issue with nvidia cards.