Unity Editor Stalls and Hiccups

I just reinstalled Unity to version 2017.1.0f3. I’ve tried this in Plus and Standard. The editor has been stalling on all of my projects by simply clicking on things in the editor (Project, Inspector, Scene view, etc.). The stalls can last from 5 seconds to 30 seconds. After the stall, that particular part of the editor works for a while, but will periodically stall again. Once selecting another tool or button another stall will occur. Has anyone else experienced this, and if so, what have you tried to fix it?

Things I’ve tried:

  • Fresh Unity install
  • New, empty project
  • Disable software such as Carbonite and anti-viruses
  • The “-force-opengl” switch
  • Collaboration tools are not enabled.

None of these things seem to affect it. Is this a common problem?

EDIT:
I’m suddenly getting this when loading a project:

Error loading launcher://unity/C:/Users/David/AppData/Roaming/Unity/Packages/node_modules/unity-editor-home/dist/index.html?code=XoRT66tBkZ0tX9WI2caOSQ002f&locale=en&session_state=eb2ae1b8dabd04fab9f034fc93adfada72be542244c81b41d37e1877336d1492.Dq3LjJv4xoXMPWiQnMW_rw002f#/login

This seems to have something to do with Oculus integration. If I disable the Oculus Services from Task Manager, the problem seems a lot less prevalent. It’s actually making Unity somewhat usable again. I’m not sure it’s 100% fixed with this, but it’s at least a lot better.

same problem, I try setting Edit->Preferences->General close AutoRefresh ,but you need manually refresh project,it will Stalls 5 seconds ,but you switch other applation not Stalls .
@cirrusplay