Unity Editor Will Not Open - Present as a Background Task

Where it happens: Unity 5.5, Unity 2017 (same symptoms)
OS: Windows 10

As the title says, when I try to open up Unity, the main form will open up fine prompting me to create a new project or open an existing. When I try to open an existing, it closes down the form and the editor never returns.

Task Manager shows Unity Editor running in the background for about 4-5 seconds, then its Disk, Network, and CPU all drop to 0 and it just sits there.

Going into the log found in AppData it always freezes at this point:

Registered platform support modules in: 0.0463381s.
Native extension for WindowsStandalone target not found
Validating Project structure ... 0.000116 seconds.
Refresh: detecting if any assets need to be imported or removed ... Refresh: elapses 0.001736 seconds (Nothing changed)

No errors detected in the log. Its stuck on trying to detect assets. Anti Virus was uninstalled. Windows Defender is disabled. I have uninstalled 5.5 and reinstalled 2017 and it gives me the exact same issue.

Cannot find a suitable solution on the forums. Any help?

Update: I tried to download Unity 5.6 32-bit in the hopes that my issue is 64-bit vs 32-bit.

Same issue. Though this time I get a bit more of a log, it hangs in the background and won't launch. Attached is the log.

3168446--241278--Editor.txt (64.5 KB)

Really? Not a single response? This is killing my project (which will be driving me picking up a pro license for distribution upon completion). I've been using Unity just fine on this machine for the past year up until a couple weeks ago.

Even something like buffing up the log so it could say what its stuck on would be ridiculously helpful.

I've now updated all display drivers. I'm running an NVIDIA GTX 1050. The only other change that happened was that I got an oculus and installed oculus drivers. I unplugged the oculus to see if that helped but it did not.

I am shut down at this point.

1 Like

More updates:

I left it running all night and day in the background to see if it would come up. Nope.

However UnityEditor.exe is taking up a sweet 1.5 gig of RAM now and UnityHelper is up to 2.5 gig of RAM and steadily growing. So whatever it is doing it is spewing memory everywhere on top of not opening up.

This is version 2017.

Last update. Reinstalled windows 10. Then clean install Unity again. Same result.

Conclusion: the log doesn't say but the only thing that changed on my machine was the GTX 1050 card and the oculus drivers.

If I had to guess I'd say that Unity doesn't like the GTX 1050 card. As no one has responded and I can't find a way to submit a bug ticket to get any help, we will have to look at using Unreal instead, because at least that editor is working.

1 Like

Same issue, I'm on a GTX 1080, i5-4690K, Windows 10 Pro 64-bit. Just started happening today, I haven't had any issues before and even used it this morning just fine. I haven't rebooted the computer since I used it, no hardware changes, nothing plugged or unplugged, but the editor refuses to launch now. I also get the UnityEditor.exe as a background process, with 2 instances of UnityHelper.exe. Editor hits about 220MB of RAM usage before it freezes, Helper instances hit about 30-40MB before freezing. I tried ending both of the helper processes, no difference. Reboot made no difference. Hopefully we can get some help in here soon.

Seems like the commonalities are the nvidia driver family we share, and the windows 10 64-bit.

Since I was running unity fine on my windows 10 box and this started once i upgraded to a 1050 card, I strongly suspect the issue lies in our graphics card drivers.

It would be grand if the editor log actually reported what the issue was. Or if someone from Unity would respond ;)

I've got a project thats seven-months old and was nearing alpha that is boned right now.

I also have the same issue, and the same commonalities as you two, I run a GTX 750 Ti and am running Windows 10, 64 bit. I have been struggling for MONTHS to get an answer as to why my I cannot open Unity, for now any Unity version past the last version of Unity 4 does not run on my PC as it just runs in the background. Would love a response from a developer etc. Side note I have tried running as admin and turning off antivirus.

Thats odd. I had a GTX 750 and it worked fine, it didn't start not working until I upgraded to the 1050 Ti.

I removed all of my antivirus software completely and it still won't open, as well as shutting down firewall.

The only other thing I can think of is paying for Unity and then forcing a bug ticket that way, but I'm not paying for the engine until my project is complete since I can't guarantee that they'd have a fix for the issue.

What platforms do you have installed for your unity version?

Can you be more specific? I don't understand what "platforms" is representing.

I think fffMalzbier means the installed package supports (windows, osx, android, ios, linux etc.). I could be wrong though. Anyways, I had the same issue today. I have a GTX 1070, and it happened on Unity 2017 Personal on Windows 10. It was working for a week before it failed, the only change was me leaving my computer on overnight instead of setting it to hibernate like I usually do. I tried uninstalling (which actually kind of did the same thing, uninstalled then closed and stayed as a process visible only in task manager), then reinstalled, but it didn't work. I found this post and tried update my graphics card driver, which I only ended up updating Geforce Experience. That didn't work so I tried rebooting my comp, now it works, not sure if it was a combination of things I did or what. Also, I get an error when launching Unity saying

Error loading launcher://unity/C:/Users/Grumpledorf/AppData/Roaming/Unity/Packages/node_modules/unity-editor-home/dist/index.html?code=J04051BuK7M3NeO-nLKipg003f&locale=en&session_state=ee555a9d2033136a7b3aa507b03dc92e8a33b5b1cbdd6371b0fcf3127c3c99a6.QBarl1V7g4kZww0gERLA3A003f#/login

Not sure if that's related.
If it happens again I'll come back here.

Glad you were able to get yours resolved. Unfortunately I've done all that to include a new install of windows and it still won't get past whatever it is hanging it up.

I'd like to add my experience to the pot. I'm a student VR dev, and I recently upgraded from a GTX 970 to a GTX 1080ti (Windows 10 x64 - Unity Personal Edition). Both Unity 5.6 & 2017.1 now fail to open any project other than the one I had last opened (and I also can't make a new project). The Editor just goes away, though I don't have any background tasks running like you guys.

I've updated Windows & also my NVIDIA drivers, and I've got nothing :/

Alright, so I found a (weird) solution that works for me.

Apparently Malwarebytes (in my case) and other antivirus programs can get unhappy with unity. I set exclusions for the Unity .exe and the folder with the rest of the install files, rebooted and now everything works.

Seems weird that upgrading my graphics card caused that specific issue, but everything ran smoothly before I did that so idk.

2 Likes

Same issue (Win10/64bit/AMD GPU). Installed 2017.1.0f3, started a new project and things seemed fine. After quitting and attempting to reload the project, the Editor simply exists as a background process. Uninstalled and tried 2017.2 beta: Editor launches fine, tinker with project, quit, resume -> same problem. Editor fails to appear and sits as a background process. On one occasion I left computer unattended for 15-30 mins, and when I came back the Editor was on screen. Whatever Unity is doing or attempting to do, it's taking a very long time to do it. This pretty much renders the app unusable...

1 Like

Same Issue (Win 10/64bit/Intel CPU/NVidia GTX 1070). If I start my PC and open Unity, it normally opens the normal instance but upon changing project or closing and opening the same project, it will appear as a background process and stay there. Upon now, the only things that I have done to try to fix it and keep working, is closing session or worse case, restarting my computer, but it is impossible to work like this specially since I'm using Unity Remote and sometimes I forget to connect the phone before opening the unity instance.

In my case (Unity 2017), the editor log stops at "Cancelling tasks, domain is going down", my work-around for now is:

  • Kill the Unity Editor
  • Delete the Temp folder in project
  • Delete the Library/ScriptAssemblies folder in project -> Sometime this step can be skipped, and it still works
  • Open again, if still not working (not often), go to step 1

Hope it can help somebody. But really need Unity to check this bug, it is unpredictable and annoying.

Note that the editor sometimes open normally without doing the work-around. New project does not suffer from this bug, so I think my project (which runs fine on Unity 5.4.x) has something in the scripts (or libraries I use) conflicts with Unity 2017 (hence the deleting ScriptAssemblies folder)

4 Likes

I am/was having the same problem. Win 7 latest version of unity, GTX 1060 3GB.
Phucvin your method worked for me just now. Thanks!