Unity editor windows content texts are broken on MacOS

Hello everyone,
Like i've shown you below the unity editor window content texts are broken on Macos Ventura. Small squares appear in place of each letter. Has anyone encountered such a problem before?

Unity version : 2020.3.31f1
8541680--1141283--Screenshot 2022-10-26 at 19.45.09.jpg

2 Likes

I was worried I am the only one. Follow this thread

Same problem

Is this with the project set to Metal, or not Metal?

Happens for me in 2020.3.24 but not in 2021.3.11.

Happens to me on 2020.3.41f1 but only in the inspector, when selecting multiple gameobjects

yeah same for me. Tried to reinstall a new editor version but nothing change

Probably found a solution.

MacBook Pro 2019, MacOS Venture 13.0 - Unity 2020.3.41f1

Go in Project Settings > Player and expand the Other Settings tab (Desktop tab). Check off the Auto Graphic API for MacOS and add the OpenGLCore.

8549690--1143023--upload_2022-10-30_10-43-0.png

After the editor restart, every thing should be resolved.

8549690--1143026--upload_2022-10-30_10-43-8.png

15 Likes

Hello, for some reason I don’t have OpenGLCore. I tried to change Color Space - Linear and Gamma

8549891--1143107--Снимок экрана 2022-10-30 в 15.48.13.jpg
8549891--1143110--Снимок экрана 2022-10-30 в 15.47.16.jpg

You have to be in the desktop tab as i said in the previous post.

1 Like

Still doesn’t work. Editor and hub rebooted

8550557--1143272--Снимок экрана 2022-10-30 в 22.55.51.jpg

Thanks so much, definitely solved it for me.
I was also having some performance issues after a few minutes with the editor open, will report back if that changes.

Macbook Pro 2019 16" (Intel) here btw.

Could be the switch from Metal to OpenGL. MacOS unfortunatelly has been optimized to use Metal.

Just look at your screen. It doesn’t work because you still toggle the wrong option.
you HAVE to toggle AUTO GRAPHIC API FOR MAC (you change for Linux). Just put more attention and probably it start working again.

1 Like

Thank you very much!!!

Awesome thanks!

if you not solve it, change the API list's order

= metal
=OpenGLCore

to

=OpenGLCore
= metal

so editor automatically restart and the problem will be solved
(sorry, my English may be idiot)

8 Likes

Thanks for the report. We are investigating.

Please note that OpenGL Core will offer degraded performance compared to Metal, so remember to go back to Metal once the fix is available.

Update: We were able to repro the issue (only on 2020.3) and are working on a fix.

1 Like

I have a fix on the way for the text/texture problem in 2020.3. You can track the progress here:
https://issuetracker.unity3d.com/issues/text-is-replaced-with-white-squares-when-opening-package-manager

Can confirm this also happens on 2019.4.40f1 on a 2019 Macbook with macOS 13.0.1