Unity Editor won't open project.

I can’t open any projects after an update to Unity 5.5.1f1 from 5.5.0f3. I usually keep around 3 versions of Unity (for different projects that use these different versions.) I haven’t had a problem until after installing the update, and now, if I try to use any version of Unity to create or open a project, it shows the importing assets dialog then closes and stays as a background process forever (I think two hours is enough for it to load) until force closed.

I have already reinstalled 5.5.1f1 3 times, backed up and deleted folders in appdata and such but I really don’t know what to do anymore.

In my case it was a USB device (a game controller) Unity didn’t like. Once unplugged it opens the projects again.

Unity still won’t start unless I restart the computer. While it’s not too bad as my startup time is pretty fast,I have to lose all of my previously open windows
Here’s the old comment:

I guess what I’ve learned is: if you delete random folders that contain the word “unity”, restart the computer, and reinstall, it’ll work…

(Deleted appdata [roaming and local], program files, all versions of unity, and reinstalled)

Here’s a thread on what is probably the exact same issue: https://forum.unity.com/threads/unity-editor-will-not-open-present-as-a-background-task.486216/. Also this thread: https://forum.unity.com/threads/unity-cannot-open-any-project.497621/

A unity mod posted these 2 workarounds:

We are experiencing some problems with our DNS server, and it's affecting intermittently. We don't have a fix yet, but there are two workarounds:

Workaround 1: Disconnect the network.

Workaround 2: Add update.unity3d.com

To /etc/hosts (Mac) or C:\Windows\System32\drivers\etc\hosts (Windows).

Please, use one of these to solve the issue for now.

Hope this fixes your issue!

I’ve been having this Issue as well… I’m not sure if it’s my Firewall(Using Windows Defender) or my MalwareBytes, but I made an exception for my Unity Folder and File in both of them, restarted my Comp and all has been fixed so far. Hope this helps!

How I fixed it : I unplugged my Xbox gamepad usb dongle from my laptop , started unity and had no more issues with it not starting. I then plugged back the gamepad and everything was OK.
Don’t know why it happens though.

Hello guys. Unfortunately I have the same problem. I 've tried everything. Do you have any solution to recommend???
Thank you,