unity exe build file administrator authority setting

Is it possible to set the exe file built with Unity to always run with administrator privileges when executed?

This is completely out of the scope of Unity. First of all no appliation should run with admin privileges except it’s an actual extention of the OS. This is a very specialized and rare case. The privileges settings of files are OS specific and file system specific, so there’s no general solution.

Apart from that Windows is managing the App compatibility settings in the registry under the registry key HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers.

You need to make yourself an Administrator or an new Administrator account. You also need to run Unity as Administrator. Then try it. If it doesn’t work try to reinstall Unity not in the C: drive and also save the project at not the C: drive. If it work/doesn’t work notify me.