Unity Executable and WebGL blurry in comparison to scene-viewer

After exporting my pixelart game as an Executable or WebGL, everything looks very blurry.

This is my first game, so I really don’t know what the problem could be.



What I have set up/tried to fix the problem:

-Pixel Perfect Camera (Pixels Per Unit 16, Reference Res. 320x180)

-Importing my sprites without filter (and so on)

-On my export settings I have set the Resolution to 320x180

-At the Project Settings, Quality is set to Ultra,

-Texture Quality is set to Full Res

-Filtering is Disabled


I would be very thankful for any help.

I was able to fix it!

After 4 hours of trial and error, I found out that I hat to unchecked “Stretch Fill”. Now everything is super crisp.

I hope this helps someone who encounters simmilar problems.


Maby if it’s a pixel game try changing sprites “Resize Algorithm” from “Mitchell” to “Billinear”.
Or maby you shouldn’t export with resolution of 320x180 but full HD (I think this is the problem).