Unity font textures not readable?


I tried using this script to save the font texture :


but I get this error : "UnityException: Texture 'font Texture' is not readable, the texture memory can not be accessed from scripts. You can make the texture readable in the Texture Import Settings."

Is there something I can do, or did unity changes make this type of scripts impossible?

In Unity 4.3.2f1

  • Select the font
  • Make it unicode (somthing different than Dynamic)
  • Click the gear in the top right corner > Create Editable Copy
  • Select the font texture sprite and set Texture type to advanced
  • Tick Read/Write enabled
  • Set format to Alpha 8
  • Apply
  • Save Font Texture… (script provided by OP)

Found it on my own : The "Character" import setting must not be "Dynamic" (for example, "Unicode") in order for unity to generate textures, and then it is accessible.

still not work

First, set “Character” to “Unicode”(for example), as Noam wrote.
Second, select on editable copy of texture “Read/Write Enable” check box :slight_smile: You are welcome)