Unity freezes when dealing with scripts.

I had recently had a problem with my anti-virus (Total Defense) where it did not give Unity 4.3.3f permissions to write to my secondary drive. This problem was fixed and now I run into this.

I simply created a new project and created a script (by right clicking and adding it) once that was done Unity froze and was unresponsive. I closed Unity via task manager and tried to open it again. Upon doing so the editor did not even show up. So I decided to delete the script (which had nothing in it) and that solved that problem. I also noticed that when I made the script it did not generate any of the solution files associated with it. I am currently using Windows 8.1 Pro (x64).

I am losing patience with Unity as I have been dealing with problems like this all week with no results from Google, UnityAnswers, StackExchange, or StackOverflow. If anyone has the solution to this problem please let me know, you will be a lifesaver.

Are you using mcafee? It used to give me alot of trouble a couple of weeks ago. I suggest you disable realtime scanning. If it doesn’t work uninstall mcafee and download avg free. That’s how I got it fixed