Unity freezes when opening Visual Studio

I use Visual Studio Community 2015 in Unity for a few month now and it always worked well. But since today Unity won’t open a script in VS, but instead freezes. Everything woks fine when using MonoDevelop, but I prefer VS.
Thanks in Advance!

I experienced the similar situation, so I’m leaving a note.

In my case, the previous Unity Editor process had not completely finished and remained for some reason. Killing all Unity Editor processes could fix it. or just reboot your OS

This drove me nuts … but a reboot fixed for me too. Never found out why but VS 2015 just wouldn’t work … instantly froze Unity if I tried to edit a script (Mono Dev worked fine but who wants that! heh…)

I’ve been having this problem with it freezing in version 2019.3.2 and 2019.3.1 with visual studio 2017. Everything was working for many months prior to that. I tried killing off all the unity tasks a few times with no luck. I also make sure to update all my packages after the update and I re-imported all assets.
None of these things seems to be the solution to unity freezing when I try to open a script.

This still happens. Reboot does work.

System restart actually fixed this issue for me.

You could just open visual studio before opening unity.
Though if you forgot to, and visual studio opens but unity freezes, you keep visual studio open and end the Unity program in the task manager(Right click on taskbar, click task manager, find something along the lines of unity, right click and end task), then relaunch unity