Unity game build will only run on design computer

I am trying for the first time to test my game build on other computers but it will only run on the machine I did the design on. I have compiled a build and can run it on the design machine without any problems, but I have tried to run the same game on 3 other machines and all of them crap out after the Unity splash screen has been displayed. I have copied the same information to the other computers (the EXE and the Data folder). All 3 machines have different OS’s, Win 7, XP and Vista. The error appears to be pointing to the mono.dll but why would it run ok on the design machine? Has anyone run into this issue before. I had just installed Unity 3.4.1f5 and reinstalled just in case there was a issue, but this has not fixed the problem. Any insight would be greatly appreciated.

Solved the problem after further testing. First unloaded all the levels and added them one at a time to find the one causing the issue. Then unloaded all the scripts in that level and loaded them one at a time until I found the script that was causing the issue. I did not have to change any code thankfully, I just removed the script from the object and then reattached and saved, tested again and it worked as expected. Not sure why it worked fine on the design machine though… A good night of sleep can work wonders.