Unity game doesn't update when code changes

Whenever I make a change to the code and I press Play, the game runs as if I hadn’t changed anything. The only way around this is restarting Unity, which takes almost 5 minutes, so that’s not an option. The asset itself does get updated, as when I click on it the inspector shows the up-to-date file. Also, Unity does compile the file to the Library/ScriptAssemblies folder (I’ve checked with dnSpy and the changes do apply). It seems as if Unity uses an old version of the DLL only when running the game. I’ve tried restarting unity, reinstalling unity, recloning the game repo, restarting my pc, nothing works.

This is incredibly annoying and is making me unable to work on my game. Does anyone have any ideas?

Unity version: 2018.2.10f1. Also tried on 2018.2.2f1 and 2018.1.9f2.

Delete the library folder and temp folder from project. Your issue would be solved. Unity have these few bugs. Please tell us which version you are using. So that I can dig a bit in it.