Unity - Gravity stopped working in my project

I am using Unity 2021.3.3f1. I have a test scene with a cube at height 10 with a rigidbody and a box collider. The Rigidbody has use gravity checked and is kinematic unchecked. The box collider is not a trigger. Below the cube at height 0 there is a plane with a mesh collider.

In the project settings under physics in the gravity settings the Y was set to 0. (I did not change this and don’t know how it changed). I changed it back to -9.81. Gravity is still not working. Yesterday my project was working fine (I have other scenes beside the test scene in the project), and today the physics is not working - the cube is just staying there midair, and none of my other scenes work. I know the rigidbody and box collider setup for those are correct, because it worked previously. I re-checked the physics settings and the gravity is still at -9.81 in Y.

I created a new project, built the exact same test scene and it is working. The physics settings of this one and the first one are the same. The cube falls to the ground. Any changes I make to the gravity in the physics settings work as expected.

Please, any assistance will be greatly appreciated, as I am desperate at this point. What do I do to fix it?

@lindalabuschagne I’m sure it’s too late for you, but I had the identical problem. Turns out that (for some other reason) darn Unity crashed and the it apparently, and for reasons only know to its tiny brain, changed the timescale to zero!! So, put it back to a value of 1. All is fine in the world, at last. This is under Project Settings/Time.

I have the same problem just rn and the timescale is on 1 :frowning: so I really don’t know where the problem lies…even chatGPT is of no help…my object is just flying, it seems quite cool for it but I want this to stay on the ground! I don’t know, if you have any insight, tell me