Unity hangs but code keeps running

So I’m making a procedural generated world for my game made of chunks. It makes an array of points and tiles to make mesh chunks of 50x50 tiles. It is an island based game, and only tiles of the islands themselves are actually rendered in the mesh, so that means the mesh isn’t really 50x50, the islands are usually pretty small as seen here:

The blue is just planes scaled up that i’m temporarily using as water.
As you can see this is a 3x3 chunk grid, my problem is; no matter what I do, if I make a grid larger than 3x3 acres unity will hang in a weird way. The button looks like this:
And the code itself never stops running. Just nothing happens and unity has to be closed though the task manager.
I ran though the code in Visual studio debugger line by line and it never broke, even after i ran the update loops a few times with nothing happening still in unity. Also, after hitting continue with no break points and letting it run for a while, adding a break point in an update breaks properly showing the code is still running.

I am using unity 5.3.4

After some crazy narrowing and removing chunks of code I believe the problem is here with my texturing. Without texturing the islands they load almost instantly at any size, does anyone know what i’m doing wrong?