Unity hub download failed (getting chiper errors),Unity hub 3.0.0-beta.7 cannot download any version (cannot install)

I got this error from every version i tried to download, none of them works

error.1e000065.Chiper functions.OPENSSL_internal.BAD_DECRYPT…/…/third_party/boringssl/src/crypto/fipsmodule/cipher/e_aes.c.1068. 31254088.error.1000008b.SSL routines.OPENSSL_internal.DECRYPTION_FAILED_OR_BAD_RECORD_MAC…/…/third_party/boringssl/src/ssl/tls_record.cc.298.

btw I am using the unity hub beta 3.0.0 beta 7,I kept getting these errors, like all the files the unity hub downloading all got this error:

Did you try reinstalling unity hub?

did u find solution ? cause i have same problem

it work for me rn , all i did is letting the program download & install his things without doing any other thing in parallel , also its better if u have fast internet

@testsuperplayer Are there any updates? Do you find the solution? I am encountering the same problem since yesterday. I even deleted and clean install my windows 10. Unity hub still gives the same error when I try to download Unity editors.

I’m having the same issue. Can’t download unity editor from my 3.4.2 hub.