Unity Hub Not installing the Editor on windows 10

I tried to add an install with the Hub but it doesn’t get installed, last time I reported this bug I got a response saying that this was a known bug and they were working on it. So and update arrives for the hub and still having this issue. If you can’t ensure that the hub will be able to install any editor version at least don’t hide the links to the editor installers in you web page please. Also, logs will be amazing and would help to solve this issue (and any other issue) a lot.

10 Likes

Hi @IamKayrox ,

I am a little confused by your post. We test on Windows 10 every day and thoroughly before every release. I can assure you that we don’t publish a release of the Hub if installing Unity doesn’t work. You mentioned you had reported this in the past and someone wrote it was a known issue. Could you please provide a link to this previous post? We may be able to gather more context from it.

Also we never hid the links to the Download Assistant. If you wish to install Unity the classic way you can still do so by visiting our download archive and selecting the “Unity installer” option for your desired version of Unity.

And finally we’ve had logs for a long time now. When you report a bug through our bug reporter (available from the tray menu) they will automatically be bundled with your issue. If you wish to consult them here is where they are on Windows:

%UserProfile%\AppData\Roaming\UnityHub\logs

If you provide more details as to how your installation is failing and possibly a link to past reports we may be able to troubleshoot your issue and make the Hub work for you as well.

Cheers,

2 Likes

I also have issues with the Unity Hub. The install takes hours to complete, and seem broken afterwards, as I can not add modules to the install.

7 Likes

I also encountered this, the hub would install but installation of the editor would silently fail.

The solution for me was to add a system override for Mandatory ASLR, as the unity installer won't work with it.

  • Go to "Windows Security"
  • App & browser control
  • Exploit protection settings
  • Program settings
  • Add program to customise, choose the unity download assistant, e.g. UnityDownloadAssistant-2019.2.12f1.exe
  • Find "Force randomisation for images (Mandatory ASLR)"
  • Click override system settings, then turn the slider off
  • Click apply
  • Repeat this process for UnitySetup64.exe as well, because that also needs an exception.

Crazy that a new program being developed in 2019 needs an exception here.

32 Likes

That worked! Thanks a lot.
I think you need to look into this, @AbrahamDUnity .

2 Likes

I even tried to introduce unity from an external installation, but it would report a “unity language error”

I was about to reinstall my windows after trying everything. You just saved me hours of making backups and stuff. Thanks sir!

2 Likes

is the 10th time that i try to download this version of unity on hub. im having the same issue

4 Likes

Guys from Unity! It is not funny even/ 3rd pc ? where I have trouble with unity hub doesn’t want to install unity editor. + When I choose in preferences Visual studio it stop to open scripts complietly. When I don"t fo tht - I have no intellisence of unity scripts. And it happened the same every time/ Help only deleting everything with hub and install back

2 Likes

stupid kind of it never wanna install please help

:expressionless:

I think you should test the hub in different network environments, do not perform the test inside the corporate network.
We use Unity in different location, have different network operator and network quality, I saw a lot people say they can’t install Unity through Unity Hub, and I also meet the same problem.

5765416--607324--upload_2020-4-26_9-43-43.png

5 Likes

I am facing the same issue

yup, still a problem for some of us, and I'm on fresh windows, all updates (GPU too) no weird security stuff. Tried 4 times - didn't get any errors, just hung, even left it overnight. The post above helped, and I also used the non-hub installer. I also have Unreal Engine installed - maybe they don't want to coexist :p

I've been having the same issue too. I just got Unity today, and I have been having the same problems with installing Unity Editor. I tried multiple times reinstalling it, but it keeps saying that a file has corrupted, or something.......?
I really want to fix this problem soon, so I can really get really into game making!:sweat_smile:

1 Like

Still a problem. No errors, it just pseudo-installs.

I don't think I've ever had a trouble-free Unity installation.

1 Like

Having the same issue.

In 4 of 5 cases it says "Failed to download file (filename)" and the installing indicator just disappears.
In 1 of 5 cases the progress bar goes to end and just hangs there for any amount of time. No errors, no any messages, just endless "installing".

Is there a way to make it work?

2 Likes

Hi guys i had the same issue many times but after talking with their support we found the best solution is to download unity through the (Unity installer) which you can find at Download Archive. The unity installer will allow you to add modules and it wont fail to download…hope that helps

6 Likes

I also had the same issue. Installation through the hub is not possible, it does “pseudo installs” as described by the others. The “system override for Mandatory ASLR” does not help in my case. Indeed, as pointed out by eugenegrandeira, installation via the Unity installer yields at least a Unity version, however, you will be unable to add modules afterwards. In my case I’m missing the modules seen in the screenshot below (although I selected “Android Build Support” in the installer). These modules must obviously be installed through the hub.

1 Like

Hi @stefan_mueller ,
Which version of the hub do you use ? There were some issues with the destination of these modules after install but it was fixed, so if you installed it through the hub it should be working and detected by the editor in the right location.