Unity Hub Sign In Window - Blank.

I installed Unity Hub and clicked sign in and a new window popped up that is just blank. I tried waiting and running as administrator. I've tried reinstalling it but same deal.

8GB DDR3 RAM - EVGA GTX 1080 8GB - Windows 10 Pro x64 - Gigabyte Mobo

3366480--263813--unityhubwhitescreen.jpg

4 Likes

what happens if you close the window with the 'X' in the top right corner?

It just closes that window. When I click to sign in again it displays a blank window again.

[edit] I just updated my graphics card drivers and same deal. Rebooted the PC and it does the same thing again.

3 Likes

That window is populated from a web view. Do you have a firewall set up? You should ensure that it allows the hub to connect to the net.

1 Like

Same here.

First, the "Loading..." page hangs for 60 seconds.
3368227--263980--hub1.png

Then "Welcome..." page appears with the login button that opens a completely blank window.
3368227--263981--hub2.png

I was thinking I could specify the license file manually but the link "deploy a license file" does nothing.

Windows 10 Pro x64. No special firewall rules, MS Edge and IE 11 (both x86 and x64) work fine.

3 Likes

If I launch Unity Hub for the first time, nothing visually happens, no windows at all, but I see two "Unity Hub.exe" processes running.
3368280--263986--u2.PNG

If I launch Unity Hub for the second time, I get three processes running and this time see the window: 60 seconds of the "Loading" page and then the "Welcome" page that doesn't work.
3368280--263987--u3.PNG

If I close all the windows, the third "Unity Hub.exe" process goes away but the previous two continue running until I kill them manually.

@Amon_1 and @alexzzzz are you able to reach https://id.unity.com guys ?

[quote=“mathieub”, post:7, topic: 689502]
@Amon_1 and @alexzzzz are you able to reach https://id.unity.com guys ?
[/quote]
Yep.

I can send you Process Monitor logs if you like.

1 Like

@alexzzzz Unfortunately, I don't think Process Monitor logs gonna be a great help here.

Could you please do the following:
1 - Closes all Hub processes (ensure nothing left in the Task Manager)
2 - Start an editor (through the Unity.exe)
3 - You gonna land on the "old" launcher, from there, try to sign in an let me know if you face the same issue

Thanks a lot for you collaboration!

I have 4 installations:

2017.1.3f1, 2017.2.1p1, 2017.3.0p1 -- these three asked me to login.
2018.1.0b4 --- this one opened the list of my projects.

I checked all the installations first and then successfully logged in using 2017.3.0p1. No problems, everything looks normal.

Let me get someone from the sign-in team to see if they can find the problem

It works!

3368534--264015--hub.png

Same problem here:

  • Install Hub and launch it
  • First window invites me to login or create an id. I click to login
  • New window opens but is blank and remains blank.
  • I close the blank login window using the X, click again to login, same thing.
  • I close the hub, run it again, no window shows up at all.
  • I look in the task manager and see two Unity Hub processes.
  • I kill the one with more memory allocated (~80MB) and both vanish.
  • I run the hub again but no window shows up at all. 2 Unity Hub processes in Task Manager, rinse and repeat.
  • I open Unity 2017.3, it logs in automatically just fine.
  • I close Unity 2017.3, open hub, no window shows up at all.

I haven't rebooted yet.

Yesterday my Windows (Insider Preview) decided to update and I agreed. After the update the issue with the hub had gone. I thought it was a coincidence and the guys did actually fix something.

1 Like

Computer freshly rebooted, same behaviour: I launch the Hub but no window shows up, just two processes in the Task Mananger, one taking 75MB the other 35MB.

I uninstalled and reinstalled the Hub, and noticed that after installation it auto-launches itself. But just as described, the window doesn't show up, just the two processes. Whehn I installed it originally, it did seem to run automatically, but I assume it ran the two ghost processes just like now.

So I launched it again without killing the existing Hub processes, and the window appears (along with a 3rd process now). Same behaviour as the first post, blank login window.

If I kill everything and launch the Hub twice then the Hub window shows up consistently. But the login window will still be blank.

(Windows 10 64-bit fully updated, Hub 0.11.0)

I am facing similar issues with unity Hub. Canot login to my account.
And it also cannot download the Learn section "01 : Play & Edit Mode " tutorials or any of the tutorials.

yep same 2 issues: Both on hub AND unity when it was fine yesterday.

Several minutes later, it finally loads the main screen -- however, signing in results in indefinite white screen

I have a feeling it may have to do with init loading -- there's no way the first loading should take that long. I think it actually timed out BEFORE getting to that screen. However, internet works fine -- I can sign in fine within Unity. That ID link posted above works fine for me. Using default Windows 10 firewall.

Something else I noticed: Checking license if I open directly is going a bit crazy and is also indefinitely staying here:

Every 1/2 second, the center text flickers. Every now and then, I'll see the top bar appear and load to 100% in only 1 second. Then poof. It seems like it's pinging every 1/2 second and failing (which is in my head when you said firewall). However, I've authed fine for the past few years: It's only when I started using Hub and 2018 (originally 5.6). Even then -- I signed in fine earlier. I really don't know what's causing it, but it seems server-side.

I'm stuck! I can't get in anywhere.

To add, the license check is also super jumpy ^

This issue seems intermittent: I found a workaround (not a solution) to manually activate by disabling the internet. I'll then be prompted to a URL to copy+paste something, download a file, then upload it back to Unity -- then enter my serial again. I then turned on my internet again. After this, both hub and Unity started working again.

Who knows how long until it starts doing this again. I found an FAQ about this that was useless -- turn off antivirus (first thing I tried), ensure firewall isn't blocking 80 or 443 (that's literally http and https/ssl/tls -- no one blocks those or they wouldn't even be able to download Unity or even post here -- or anywhere, for that matter, haha). Then an unstable connection (I'm on a cat6 wired 450mbps connection using Google DNS - no way).

This is absolutely a Unity issue. If it wasn't, I wouldn't be able to sign in just fine after manually activating (especially since a mod above confirmed the same id url is the access point for all the related sign-ons).

1 Like

Same here except I can clic on my project in Unity Hub, it's loaded and then a white screen stays there:
3800269--319291--PrtScr capture_27.png