Unity input system can't select stick

I’m trying to use unity’s input system to use a PS4 controller with my game. When I go to select the left stick for the movement controls I press listen and move the stick, but only the specific left, right, up, down options appear not the option of selecting just the stick. Also when I search for it with the drop-down menu both the sticks and the d-pad are greyed out only letting me select the individual directions. Any reason why this is happening?

just stumbled over the same issue, the reason why you can’t select “leftstick / rightstick” is that the Move Action (green icon) needs to be set to Action Type: Pass Through and Control Type: Vector2.
Plus there is a difference between clicking the plus icon and right clicking the Bar of your action.

Hi @Fallout267. First time posting here, so excuse me if the formatting is not correct.

I’ve been experiencing the same problem as you do though in my case is with an xBox controller. I’ve solved it by going into the “Bindings/Paths” and instead of selecting the dropdown I clicked the “T” button. Once clicked I changed the string from “/leftStick/up” to “/leftStick” and it worked fine.

Here is a sample of the code I use to get the values in case you have trouble with it. I have the input actions inside the controls class and, in my case, the action Move is the one associated with the Left stick

controls.Gameplay.Move.performed += (ctx) => {v = ctx.ReadValue<Vector2>();}

Attaching a snapshot. I hope it helps you.

alt text

I swear when I first started with the Input Actions asset, the first action allowed me to select the sticks, but I was unable to get the Add 2D Vector Composite option to show. I got the latter one to show by clicking out of the action name and then right-clicking on it again.

I still have to test if this will work, but I was able to get the binding by:

  1. Make a new action
  2. In this action, set the Action Type to ‘Value’ and the Control Type to ‘Stick’
  3. Now click the plus (+) for this action and choose ‘Add Binding’
  4. You should be able to select a stick, now.
  5. When done, you can drag the binding from the new action to your movement action (if you previously defined keyboard bindings, etc.). Just be careful to not drag it into the middle of child bindings if you have a composite binding (2D vector for movement, for example).

Using the answer from Reykos, I clicked the ‘T’ in the binding path of my new action (created in step 4, not yet moved). My binding path said <Gamepad>/leftStick

(Now that I typed that, I see the screenshot in the answer does have the <Gamepad> part of the binding)

I’m in the most current stable version of 2019.3.13f1, and this UI definitely seems buggy and needs some work.