Unity Inspector stuck on one object,Unity Inspector stuck on one item (Not locked)

The inspector is currently stuck on one object, and I can’t focus on other objects in the scene. And no, the inspector is not locked, I also tried locking and unlocking again just to make sure, and no the problem wasn’t that. What could be the reason for this?,I tried editing a scene in Unity today, and when I clicked on one object, it was focused in inspector. This is normal behavior, but when I clicked any other object on the scene, the inspector left focused on the same object. I tried locking and unlocking the inspector tab, and it sure wasn’t the solution. Any other reason this could be happening?

I have a solution, try to enable and disable debug on inspector, it works for me

Ok, I’ve found a solution that works for me.
Or rather discovered when this issue occurs.
Occasionally when I use “V” snapping or “shift+move” it gets stuck in the inspector.

Simply use"shift+move" again and then undo + deselect.

Edit: Managed to record me doing the fix:

It happened again today. Grabbed a video of the problem, Shift + drag fixes it!

going to debug and back makes it refocus on whichever new object you’ve selected, but then it stays focused on that object until you toggle debug again. It’s hard to believe that a game engine would have such a bug.
Edit: Turns out restarting Unity cleared the bug.

This is still an issue for me, I’ve been tracking this for quite sometime. All the above suggestions work, specially the debug which I discovered after a bit of frustration (prior to this thread).

Restarting unity corrects this for a period of time BUT if you have a large project, which I do, this is ULTRA time consuming and unfortunate.

I’ve noticed it occur after hours of working, or within a few seconds so I highly doubt it has anything to do with any specific functionality performed by users because I’ve had it occur under any / all situations and I’m not really using any of the above suggestions during these times.

I submitted a bug report over a year ago, then another, and another…now I’m here.

I’ve tried reinstalling unity, creating a test project, using different versions (current 2019.x+), all seem to have this issue occur eventually. I’ve been a unity user for some time now…this is a new “feature” that’s not super appreciated ;p

…not to drone on, but it takes roughly 8m to open my project currently, by days end I lose no less than 1.5 hours fk’n with this (that’s 11 reboots btw).

Kinda glad to see I’m not alone having this issue.
The normal < > Debug fix works, but it’s not a solution I can work with…
There’s got to be another fix??

Also have this issue… Been going on for quite a few 2019.3 versions…

I dont know either i have the same bug. I tried to force refreshing everytime I select a new object but that doesn’t work either.

I was able to reproduce this.

Using the “V” to snap vertices - if an accidental selection of multiple objects happens when attempting to move the vertice, and you then press Esc to cancel the operation (not sure if Esc is required to produce the bug), the Inspector will then hit this problem/bug. Restarting the Unity Editor is required to make it fully functional again.

Tested on Unity 2019.4.9

Hi. Just wanted to say it also happens in 2020.1.4f1

This problem just cropped up for me, too. 2020.1.12f1 and 11f1

I can select objects in the scene view and in the hierarchy, but the inspector never switches to the new object. Entering playmode causes the selection to suddenly switch.

Has anyone come across a fix for this yet?

I suspect it’s a registry problem, or something. I doubt filing a bug report will help, since Unity will most likely be unable to reproduce the problem on their end, even if you send them your project file.

Happens for me too. Restarting does not fix it. Happens every 10-20 clicks Now.
Restarting used to fix it.

Set the inspector to debug and then normal again.
Doing that everytime you select an object, so 1000 times in a day is ridiculous. It’s still present in the new version. Unity team, do something instead of laying of 250 devs…

still an issue in 2022.3 …