Unity installing old versions while I got new version.

Hello.

I have some task to do. They asked me to do it using flash and I know that 3.5 versions only support it. However, I already have got 4.3.5 version. If I install 3.5 version, can it be on conflict with my new already installed version??

Also, does 3.5.7 version supports flash? Because this is last 3.5.x version.

Here is a guide on how to install multiple instances of unity at once:
http://docs.unity3d.com/Documentation/Manual/InstallingMultipleVersionsofUnity.html