Unity instance missing in "Attach Unity Debugger", Visual Studio 2013. How do I fix this?


I used this feature a lot on another computer and i recently installed Unity, Visual Studio 2013 and Unity Tools for Visual Studio - 2013.

The problem that I’m having is when i want to use the VS debugger with unity, the “Select Unity Instance” window is empty (meaning no instance is there).

I’ve never had this problem before and can’t seem to find anything about it.

You have to import “Visual Studio 2013 Tools” package into your current project in Unity. Then select “Open in Visual Studio” item under “Visual Studio Tools” menu inside Unity editor. Now you should see your scripts in VS which is already connected with your Unity instance. Hope it helps.

For everybody who also has the same problem: The unity.exe is not allowed to be renamed ( I usualy renmae it +VersionNumber ), but looks like newest version doesnt like that anymore.

I also meet this situation.
I think reason for what we meet is probably the version of our unity, our VS IDE is 32bit but unity we install might be 64bit,so it’s incompatible.
last night i test it ,visual studio still only have 32bit version,the name of MSDN (x86 and x64) may mean it have 32bit and 64bit component,but not all of VS is 64bit.My Computer is 64bit,but when i installed it ,it doesn’t guide me to select 32 bit or 64 bit,and when done,I run it ,definitely 32bit from taskmanager.
So this morning ,I went to company,to install 32 bit of Unity and it works.so I have to choice either to give up VSTU or Unity64 bit version.

To solve this issue go to C ->Program Files->Unity->Editor and rename the unity exe file to "Unity.exe " remove the version extension if any

I have the same problem. What worked for me was disabling all network connections in “Network and sharing center” → “Change adapters” and enabling only one with connection to the internet. I had some Virtual WiFi Miniport adapters and one TAP-Win32 Adapter (installed by Wireshark). I guess that UnityVS plugin opens connection on different adapter that debugger is searching. I hope it helped.