Unity iOS sdk question

How do I go about finding an older version of the SDK? I'm running OSX 10.5.6 and I can't run the latest version of IOS SDK 4.2.

With running 10.5.6 is there any older SDK Version that I may use along with Unity?

You need OS X 10.6 if you're going to be doing iOS development, no way around it. It's only $30. (It's kind of odd to be on 10.5.6; if you didn't need 10.6 anyway I'd recommend updating that to 10.5.8.)