Unity Ipad app will not run on device.

Hi I recently created an iOS application in unity and tried putting it onto a device through Xcode, however after the app is built and runs on the iPad, it crashes after the splash screen comes up.

I’ve tried loads of the quick fixes that people have said to do however none work:

  • reinstalling unity
  • reinstalling xcode
  • cleaning the builds
  • checking player settings are correct

The error i get in Xcode is:

PlayerInitEngineNoGraphics settings: Could not preload global game manager #0
engine initialisation failed

The error i get in the iPad console in organiser is:

: (UIKitApplication:com.patrickgarland.piratepatching[0x5962]) Exited with code: 1
Warning>: Application ‘UIKitApplication:com.patrickgarland.piratepatching[0x5962]’ exited abnormally with exit status 1

  • Current version of unity: 4.0.1f2 (newest) basic with iOS license
  • Current version of Xcode: 4.6 (newest)
  • IOS SDK: 6.1
  • Device IOS: 6.1

Cannot figure out what is going wrong. Any suggestions?

I figured out what the problem was. It was mixing versions of unity. The windows unity and mac unity don’t mix well. Had to rebuild it all in the mac version.
Fixed the problem right up.