Unity-iPhone has Conflicting Provisioning Settings?

I am attempting to test my iPhone app with the current unity update and the current version of xcode however I am stuck with this error and have searched around online for help with little luck. I already have a personal team set up and am using automatic signing, I have also tried to use the manual build settings as well under the ios developer and personal team settings. Any help is appreciated!

.The Error in Xcode.

Unity-iPhone has conflicting provisioning settings.
Unity-iPhone is automatically signed, but code signing identity iPhone Development has been manually specified. Set the code signing identity value to “iPhone Developer” in the build settings editor, or switch to manual signing in the project editor.

From https://forum.unity.com/threads/error-unity-iphone-has-conflicting-provisioning-settings.442194/#post-3501621

  1. Select the top level node called Unity-iPhone in the left tree view (the one with the blue item).
  2. Select Automatically manage signing
  3. Select your team (now the error message should appear)
  4. Go to Build setting in the tab
  5. Find the Group called “signing” in the structured table
  6. Change the values from “iPhone Developer” to “iOS Developer”
  7. Switch back to general (the error message should now disappear)

Your project should compile now and should be runnable on your iPad or iPhone.

Same problem is here also. @E_101

Same here, found a 1 here that could be interesting but I don’t have that plugin. Could be a plugin thing…

If nothing helped,
Try building the project again from Unity to a different folder(name,location), That worked for me.

These steps didn’t work for me but here’s what I did instead.

XCODE Provisioning Settings Error - How to fix.

  1. Click over to Build Settings tab

  2. Scroll down to Signing subsection

  3. Change ALL eight of the following to Apple Development:
    Debug; Any iOS SDK; Release; Any iOS SDK; ReleaseForProfiling; Any iOS SDK; ReleaseForRunning; Any iOS SDK

  4. Click back over to Signing & Capabilities

  5. You should see two Signing sections — Signing (Release, ReleaseForProfiling, and Debug) and Signing (ReleaseForRunning)

  6. Signing (ReleaseForRunning) will have an error. The other Signing section will not.

  7. Click back over to Build Settings, return to Signing subsection

  8. Change Code Signing Style dropdown to Manual

  9. Click back over to Signing & Capabilities tab

  10. The checkboxes for Automatically manage signing will have changed. Make sure both are checked. Uncheck and check again if need be.

  11. Choose your team again in both Signing sections

  12. Once both teams match, the two Signing sections will merge into one and you can then build without error.