Unity iPhone / MonoDevelop Code Completion

Hi,

I'm not entirely sure if this is a Unity specific question or not, but hopefully someone can shed some light on the issue i'm having...

I'm developing with Unity iPhone on the Mac and using MonoDevelop as my IDE. I've got my synced code solution and MonoDevelop has working code completion, until I want code completion with XML based classes/fields. I'm 'using System.Xml' to gain access to XmlDocument as well as all the other things that come along with it, and the Unity compiler doesn't produce any errors when I run my game, but MonoDevelop is giving no code completion for any of my XML based stuff. Is there something I need to do within Unity to enable this? perhaps my sync code solution needs updating?

I have the most up to date version of MonoDevelop and Unity 1.6, though i'm currently downloading 1.7

Thanks for any advice

Mat

* UPDATE * Whilst it downloads, i have read some of the Unity 1.7 release notes which says that System.Xml can now be used in Unity iPhone Basic... Maybe this will solve the issue, but on 1.6 it didn't moan when I tried to use it... wierd.

* UPDATE 2 * Upgrading to Unity iPhone 1.7 didn't solve the issue :(

Try deleting the solution file then create a new one with Unity. I've found this issue to happen occasionally with Visual Studio and this usually fixes it.

If you add a reference to System.Xml to your project in MonoDevelop (double-click the "References" item for your project in the solution pad), you should get completion for Xml classes.