Unity is adding edges to imported fbx

I noticed that Unity is adding edges to my model. Here you can see the model inside Sketchup (where it was made)

Now here’s how Unity is changing my model.

As you can see Unity is adding an extra edge between some vertices, this is the only place where unity seems to be doing this. Does anyone know why Unity is doing this?

That makes no sense. Those faces has to be inside the model. Maybe you have somehow disabled them in sketchup but they are still there. At those points shouldn’t be vertices and Unity never adds vertices or faces.

My guess is you did not make that model yourself but downloaded it somewhere and you (or someone else) tried to remove those faces which the original author had added. However the faces are not removed but just hidden in sketchup. I never used sketchup, but a quick google showed that it has a “hide faces” feature and here’s how you can show them again. You might want to look at some tutorials how to delete a face.